IRS TIN matching unavailable
Incident Report for Middesk
Resolved
This incident has been resolved.
Posted Dec 23, 2020 - 16:46 PST
Update
IRS TIN matching is available.
Posted Dec 23, 2020 - 16:45 PST
Update
We are continuing to investigate this issue.
Posted Dec 23, 2020 - 16:14 PST
Investigating
IRS TIN matching is currently down. Business completion may be slightly delayed. We're looking into remediation.
Posted Dec 23, 2020 - 16:13 PST
This incident affected: IRS.