IRS TIN matching is unavailable
Incident Report for Middesk
Resolved
The IRS maintenance has completed and service has been restored to normal operation.
Posted 21 days ago. May 02, 2019 - 10:04 PDT
Identified
IRS TIN matching service is currently unavailable. We’ll monitor its status and send updates once service is restored.
Posted 21 days ago. May 02, 2019 - 09:29 PDT
This incident affected: IRS.