Business Creation Errors

Incident Report for Middesk

Resolved

For approximately 12 minutes beginning around 2:20 PM PT, a portion of Business Verification API requests (including new business submissions) returned errors. We identified the cause, deployed a fix, and have confirmed through monitoring that requests are processing normally.
Posted Jun 02, 2026 - 14:43 PDT

Monitoring

We've identified an issue causing some business creation API requests to return errors. A fix has been deployed and we're monitoring for full recovery.
Posted Jun 02, 2026 - 14:37 PDT
This incident affected: APIs (Business Verification).