NY UCC Lien Portal Outage

Incident Report for Middesk

Resolved

This incident has been resolved.
Posted Mar 10, 2026 - 09:39 PDT

Investigating

The NY UCC portal remains unavailable past its expected restoration date. As a result, any NY lien searches and lien filings will be delayed until the portal is back online.
Posted Mar 09, 2026 - 07:08 PDT