IRS is down
Incident Report for Middesk
Resolved
The IRS TIN matching service is now available.
Posted 13 days ago. Mar 06, 2019 - 19:29 PST
Identified
The IRS TIN matching service is currently unavailable.
Posted 13 days ago. Mar 06, 2019 - 15:28 PST
This incident affected: IRS.