IRS e-Services - Planned Maintenance: 2019/05/25 - 2019/05/28
Incident Report for Middesk
Resolved
Maintenance completed.
Posted 3 months ago. May 28, 2019 - 07:44 PDT
Update
Once service is restored, we'll work through the queue to retry any outstanding requests.
Posted 3 months ago. May 27, 2019 - 10:00 PDT
Monitoring
Via IRS e-Services website:

"This service will be unavailable from approximately 8 p.m. Eastern time on Saturday, May 25, 2019, until approximately 7 a.m. Eastern time on Tuesday, May 28, 2019, due to planned maintenance. We apologize for any inconvenience."
Posted 3 months ago. May 25, 2019 - 05:00 PDT
This incident affected: IRS.