IRS is experiencing intermittent issues
Incident Report for Middesk
Resolved
IRS TIN matching has restored to normal operation.
Posted Jul 22, 2019 - 12:08 PDT
Identified
IRS TIN matching availability has degraded due to intermittent issues. We’ll monitor its status and send updates once service is restored.
Posted Jul 22, 2019 - 08:29 PDT
This incident affected: TIN Match.