Agent Dashboard inaccessible
Incident Report for Middesk
Resolved
This incident has been resolved.
Posted Oct 18, 2022 - 15:56 PDT
Investigating
We are investigating an issue where the Agent dashboard is unresponsive upon login.
Posted Oct 18, 2022 - 14:49 PDT
This incident affected: Dashboard.