Intermittent KYC order failures

Incident Report for Middesk

Resolved

This incident has been resolved.
Posted Apr 09, 2026 - 15:11 PDT

Investigating

We are observing intermittent stuck KYC orders due to an upstream provider. Our team is currently investigating and hope to resolve the issue shortly.
Posted Apr 09, 2026 - 10:16 PDT
This incident affected: APIs (Business Verification).