Delays in processing businesses requesting litigations
Incident Report for Middesk
Resolved
This incident has been resolved.
Posted Dec 01, 2023 - 10:36 PST
Update
We are continuing to investigate this issue.
Posted Nov 30, 2023 - 12:57 PST
Investigating
We are currently investigating this issue.
Posted Nov 30, 2023 - 12:57 PST
This incident affected: API.