IRS is currently experiencing intermittent issues.
Incident Report for Middesk
Resolved
This incident has been resolved.
Posted Sep 14, 2020 - 09:20 PDT
Monitoring
We're currently monitoring intermittent issues with the IRS TIN/name matching service.
Posted Sep 13, 2020 - 10:07 PDT
This incident affected: IRS.