Delays in email delivery and Middesk Agent sign-in

Incident Report for Middesk

Resolved

Email delivery was restored by 8:25 AM PT, and the backlog of queued messages finished delivering at 9:01 AM PT. No messages remain queued.

Remaining actions for affected customers:
- Middesk Agent sign-in: Magic-link emails requested during the outage were not delivered and will not be retried. Please request a new sign-in link.
- Verification codes and dashboard invitations: Emails delivered from the backlog — including state agency verification codes and guest dashboard sign-in links from Entity Management — were generated up to three hours before they arrived and may no longer work. If a code or link fails, please request a new one.
- Duplicates: A small number of messages were delivered more than once; duplicate copies can be disregarded.

Our APIs, verification processing, Signal, and TIN Match were unaffected throughout.
Posted Jul 28, 2026 - 10:43 PDT

Monitoring

Between approximately 5:30 AM and 8:25 AM PT, outbound email from Middesk was delayed or not delivered. Email delivery has been restored and queued messages are now being delivered.

During this window:
- Customers using Middesk Agent were unable to sign in with a magic link.
- Email notifications across our products were not delivered, including verification codes needed for state agency portals. State tax registration filings and related ID retrievals were delayed as a result.

What to do:

- If you requested a sign-in link during this window, that email will not be delivered — please request a new one. Links expire 30 minutes after they are sent.
- Queued notifications are being delivered now. Some will arrive late, and a small number will be delivered more than once; duplicate copies can be disregarded.
- Verification codes delivered late may have expired; request a new code if needed.

Our APIs, verification processing, Signal, and TIN Match were unaffected throughout.

We are monitoring delivery of the remaining queue and will post a final update once the backlog has cleared.
Posted Jul 28, 2026 - 09:04 PDT

Update

We are continuing to investigate this issue.
Posted Jul 28, 2026 - 08:21 PDT

Investigating

We are investigating an issue affecting outbound email delivery. Customers using Middesk Agent may be unable to sign in with a magic link, and may not receive email notifications — including verification codes needed to access state agency portals.

Our APIs, business verification, and TIN Match services are unaffected. Sign-in to the Middesk dashboard at app.middesk.com is also unaffected; this issue is limited to Middesk Agent sign-in and to email notifications.
Posted Jul 28, 2026 - 08:19 PDT
This incident affected: APIs (Entity Management).