IRS TIN matching is unavailable
Incident Report for Middesk
Resolved
This incident has been resolved.
Posted 2 months ago. Jul 09, 2019 - 18:12 PDT
Identified
IRS TIN matching service is currently unavailable. We’ll monitor its status and send updates once service is restored.
Posted 2 months ago. Jul 09, 2019 - 06:37 PDT
This incident affected: IRS.