Users unable to login
Incident Report for Middesk
Resolved
Login should be restored for all users.
Posted Oct 14, 2022 - 07:01 PDT
Identified
The issue has been identified and we're actively deploying a change to resolve the issue.
Posted Oct 14, 2022 - 06:48 PDT
This incident affected: Dashboard.