Florida Identity & SOS Documents Request Delays

Incident Report for Middesk

Resolved

This incident has been resolved.
Posted Dec 26, 2024 - 10:22 PST

Identified

FL SOS is currently updating its search website through December 26, 2024. As a result, any Verification and SOS Documents requests requiring FL searches may be delayed until then.
Posted Dec 20, 2024 - 17:13 PST