Businesses are failing to create
Incident Report for Middesk
Resolved
The offending change was rolled back and Businesses are now able to be created again.
Posted Oct 18, 2022 - 16:32 PDT
Investigating
We are currently investigating this issue.
Posted Oct 18, 2022 - 16:22 PDT
This incident affected: API.