IRS TIN matching is unavailable
Incident Report for Middesk
Resolved
The IRS maintenance has completed and service has been restored to normal operation.
Posted 4 months ago. Apr 28, 2019 - 20:32 PDT
Update
We'll continue to update status on IRS service availability and monitor when service is back online.
Posted 4 months ago. Apr 28, 2019 - 11:58 PDT
Identified
The IRS is currently unavailable for planned maintenance.
Posted 4 months ago. Apr 28, 2019 - 09:00 PDT
This incident affected: IRS.