Intermittent latency issues and errors due to upstream infrastructure outage

Incident Report for Middesk

Resolved

This incident has been resolved.
Posted Jun 13, 2025 - 09:22 PDT

Update

We are continuing to monitor for any further issues.
Posted Jun 12, 2025 - 13:36 PDT

Monitoring

Service has been restored to normal operation. We're continuing to monitor the upstream incident as we process a backlog of orders.
Posted Jun 12, 2025 - 13:35 PDT

Update

Google Cloud Platform has identified the root cause and is working on mitigation (https://status.cloud.google.com/incidents/ow5i3PPK96RduMcb1SsW). We are receiving requests and slowly processing orders during this ongoing incident. We will begin to work through the backlog shortly.
Posted Jun 12, 2025 - 13:07 PDT

Identified

The issue has been confirmed to be a broader outage with our infrastructure provider. We are actively working with them on remediation and will provide updates as available.

Impact includes:
- API request errors
- Elevated response times
- Slower overall order processing for Business Verification
- Errors for downloading/exporting PDFs
- Intermittent issues logging in with "Sign in with Google"
Posted Jun 12, 2025 - 12:11 PDT

Investigating

We are currently investigating latency problems related to upstream issues from our infrastructure provider.
Posted Jun 12, 2025 - 11:41 PDT
This incident affected: API and Dashboard.