IRS is currently experiencing intermittent issues.
Incident Report for Middesk
Resolved
This incident has been resolved.
Posted Sep 08, 2020 - 15:43 PDT
Monitoring
We're currently monitoring intermittent issues with the IRS TIN/name matching service.
Posted Sep 08, 2020 - 12:28 PDT
This incident affected: TIN Match.