IRS TIN matching unavailable
Incident Report for Middesk
Resolved
IRS TIN matching is now available. Power outage maintenance has been completed.
Posted Sep 08, 2020 - 07:52 PDT
Monitoring
IRS TIN matching is unavailable starting Saturday, September 5, 2020, starting at 1 PM PT through Tuesday, September 8, 2020, at 5 AM PT due to power outage maintenance at the IRS Martinsburg, WV Computing Center.
Posted Sep 06, 2020 - 17:49 PDT
This incident affected: IRS.