CA Secretary of State site is down

Incident Report for Middesk

Resolved

The California Secretary of State is back online!
Posted Oct 17, 2023 - 11:58 PDT

Investigating

The California Secretary of State site is down and has been affecting our manual fulfillment of our identity, verify, liens and documents products in that state.
Posted Oct 16, 2023 - 15:52 PDT
This incident affected: API.