Maryland SOS Portal Outage

Incident Report for Middesk

Resolved

This incident has been resolved.
Posted May 28, 2026 - 08:56 PDT

Investigating

MD SOS business entity search portal is currently unavailable, and the state has
not provided a timeline for restoration. As a result, any MD identity and document
requests will be delayed until the portal is back online.
Posted May 27, 2026 - 12:55 PDT
This incident affected: APIs (Business Verification).