Address verification issues
Incident Report for Middesk
Resolved
Address verification has been restored and service has returned to normal operation.
Posted 4 months ago. Apr 18, 2019 - 16:41 PDT
Identified
We've identified the source of the issue and working hard to get the matter resolved soon.
Posted 4 months ago. Apr 18, 2019 - 15:56 PDT
Investigating
We're currently experiencing issues with address verification.
Posted 4 months ago. Apr 18, 2019 - 15:28 PDT
This incident affected: API.