Intermittent sandbox availability

Incident Report for Middesk

Resolved

This incident has been resolved.
Posted Sep 01, 2026 - 09:00 PDT

Investigating

We're investigating intermittent availability in Sandbox tied to an upstream cloud provider disruption. Production remains operational and is being monitored.
Posted Sep 01, 2026 - 08:50 PDT
This incident affected: APIs (Business Verification, Signal, Entity Management) and TIN Match.