Service interruptions due to upstream provider outage

Incident Report for Middesk

Resolved

Network errors have been resolved.
Posted Nov 18, 2025 - 09:04 PST

Monitoring

Upstream outage is resolving. All services are recovering or have recovered. We will continue to monitor the situation.
Posted Nov 18, 2025 - 06:49 PST

Identified

Our proxy provider is experiencing a major network outage making our services intermittently unreachable.
Posted Nov 18, 2025 - 04:51 PST
This incident affected: API, Dashboard, and TIN Match.