Delays in processing businesses
Incident Report for Middesk
Resolved
This incident has been resolved.
Posted May 04, 2024 - 12:51 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted May 04, 2024 - 12:40 PDT
Update
We are continuing to investigate this issue.
Posted May 04, 2024 - 12:21 PDT
Investigating
We are currently investigating this issue.
Posted May 04, 2024 - 12:12 PDT
This incident affected: API and Dashboard.