Dashboard and API unavailable
Incident Report for Middesk
Resolved
This incident has been resolved.
Posted Jun 21, 2022 - 00:10 PDT
Update
Users may experience errors or timeouts reaching Middesk's services. We are investigating the issue.
Posted Jun 20, 2022 - 23:46 PDT
Investigating
We are currently investigating this issue.
Posted Jun 20, 2022 - 23:43 PDT
This incident affected: API and Dashboard.