GA UCC Search Portal Outage

Incident Report for Middesk

Resolved

This incident has been resolved.
Posted Dec 01, 2025 - 09:47 PST

Monitoring

GA UCC is currently undergoing maintenance, which is causing delays in lien searches and lien document retrieval for Georgia. Middesk is actively monitoring the situation and will provide an update once a resolution timeline is announced.
Posted Nov 26, 2025 - 09:42 PST