Delays in processing Businesses and Signals failing to create

Incident Report for Middesk

Resolved

This incident has been resolved. We are actively monitoring to ensure continued stability.
Posted Feb 27, 2026 - 14:59 PST

Investigating

We are currently investigating this issue.
Posted Feb 27, 2026 - 13:50 PST
This incident affected: APIs (Business Verification, Signal).