IRS TIN matching is unavailable
Incident Report for Middesk
Resolved
The IRS has restored service to normal operation.
Posted 5 months ago. Apr 16, 2019 - 06:44 PDT
Identified
The IRS is currently experiencing an extended outage.
Posted 5 months ago. Apr 15, 2019 - 09:07 PDT
This incident affected: IRS.