Requests may be delayed due to Crowdstrike outage

Incident Report for Middesk

Resolved

This incident has been resolved. All services are fully operational.
Posted Jul 19, 2024 - 19:00 PDT

Monitoring

Requests may be delayed, as issues with CrowdStrike are impacting certain government portals that are used in the processing of some parts of our product. We're monitoring the situation and will communicate plans to any impacted customers shortly.
Posted Jul 19, 2024 - 07:54 PDT
This incident affected: API and Dashboard.