Users are having trouble logging into the dashboard
Incident Report for Middesk
Resolved
This incident has been resolved.
Posted Dec 16, 2020 - 11:45 PST
Update
We are continuing to investigate this issue.
Posted Dec 16, 2020 - 11:45 PST
Update
We are continuing to investigate this issue.
Posted Dec 16, 2020 - 11:44 PST
Investigating
We are currently investigating this issue.
Posted Dec 16, 2020 - 10:59 PST
This incident affected: Dashboard.