System Outage
Incident Report for Middesk
Resolved
This incident has been resolved.
Posted 15 days ago. Oct 07, 2019 - 06:25 PDT
Identified
The issue has been identified. We are working with the necessaries parties to restore services.
Posted 16 days ago. Oct 06, 2019 - 22:54 PDT
Investigating
We are currently investigating this issue.
Posted 16 days ago. Oct 06, 2019 - 19:34 PDT
This incident affected: API and Dashboard.